Q: Why I got error on captive portal wifi?
A: Create a file my.shim.catalina.captivenetworkassistant.plist
in ~/Library/LaunchAgents
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
| <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" \ "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>Label</key> <string>my.shim.catalina.captivenetworkassistant</string> <key>LowPriorityIO</key> <true/> <key>ProgramArguments</key> <array> <string>open</string> <string>/System/Library/CoreServices/Captive Network Assistant.app</string> </array> <key>WatchPaths</key> <array> <string>/Library/Preferences/SystemConfiguration</string> </array> <key>RunAtLoad</key> <true/> </dict> </plist>
|
Then run the command down below:
1
| cd ~/Library/LaunchAgents
|
1
| launchctl load my.shim.catalina.captivenetworkassistant.plist
|
1
| launchctl start my.shim.catalina.captivenetworkassistant
|
Restart the macOS, the issue should be solved π
If you want to remove this daemon:
1
| cd ~/Library/LaunchAgents
|
1
| launchctl stop my.shim.catalina.captivenetworkassistant
|
1
| launchctl unload my.shim.catalina.captivenetworkassistant.plist
|
1
| rm my.shim.catalina.captivenetworkassistant.plist
|
The post I reference says that this issue fixed on 10.15.1
update, but I still got this error on 11.2.3
π
Quick Fix is a series of my solution for some random problem
Reference
macOS Catalina WiFi issue β captive portal broken
Comments